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Introduction

Vast quantities of satellite data pertinent to volcano science are now publicly available at no cost
to users, from sources such as NASA and the European Union’s Copernicus Earth Observation
program. Although access to satellite datasets is relatively straightforward, processing satellite
data to extract volcanological information (e.g., mass of sulfur dioxide, SOz) can be a challenge
using commercially available software packages. Hence, most users of satellite data write their
own codes for analysis (e.g., in IDL, Matlab, Python etc.). The most common satellite data
formats are Hierarchichal Data Format (HDF, HDF4, HDF35, etc.) and the related Network
Common Data Form (NetCDF) and most programming languages have extensive libraries to
manipulate these formats.

This tutorial will introduce you to several online and offline satellite data visualization
tools, that require no programming skills to use. These tools can be used to check whether a
given volcanic event has been detected in satellite imagery and roughly estimate the magnitude
(e.g., based on SO or ash emissions), identify/download the specific datasets required for further
analysis, and produce images of volcanic plumes. As examples we will use the eruptions of Kelut
(Indonesia) in February 2014 and Ambae (Vanuatu) in July 2018, but in the materials folder you
will also find copies of current satellite-based inventories of volcanic SO emissions listing many
other eruptions for further exploration.

Required Downloads

Download NASA’s Panoply Data Viewer from here: https://www.giss.nasa.gov/tools/panoply/

Panoply also requires that your computer has the Java SE 8 (or later) runtime environment
installed (https://www.java.com/en/download/).

Provided materials

MSVOLSO2L4 Jun2019.txt: current inventory of SOz emissions by volcanic eruptions detected
by satellite sensors since 1978 (text file — can be imported into Excel). Source: NASA

NASA Ozone Mapping and Profiler Suite (OMPS) SO data files (orbits) for the July 2018

Ambae eruption (HDF5 format):
OMPS-NPP_NMSO2-PCA-L2 v1.1 2018m0726t235126 034953 2018m0727t015115.h5
OMPS-NPP_NMSO2-PCA-L2 v1.1 2018m0727t013256 034954 2018m0727t060604.h5
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Satellite data sources

NASA — Earthdata: https://earthdata.nasa.gov/ (requires free account)

ESA Sentinel-5P — Copernicus Open Access Hub: https://s5Sphub.copernicus.eu/dhus/#/home
(guest username/password for data access: sSpguest/sSpguest)

NASA Global SO2 Monitoring: https://so2.gsfc.nasa.gov/ (daily SO2 maps of volcanic regions
from UV satellite instruments and a portal to various other sources of volcanic SO data)

1. Web-based satellite data visualization with NASA Worldview

This first exercise is a simple visualization of satellite data using NASA’s Worldview interface
(https://worldview.earthdata.nasa.gov/). Worldview is an excellent tool for browsing and
visualizing available global satellite data for a given volcanic eruption (decades of satellite data
are available, updated within 3 hours of observation), though only minimal quantitative analysis
is possible. Apart from visualization, its main utility is to identify available datasets which can
then be downloaded directly from Worldview or other source(s) for further analysis, if needed.

a) Open NASA Worldview in a web-browser. This should open a global basemap for the
current day (change the date using the year/month/day counters in the lower left of the
window, or the time slider along the bottom). The default base layers are ‘true-color’
visible satellite images from the Moderate Resolution Imaging Spectroradiometer
(MODIS) instruments aboard the NASA Terra (~10:30 am and ~10:30 pm local time
overpass; available since 2000) and Aqua (~1:30 pm and ~1:30 am local time overpass;
available since 2002) satellites, and the Visible Infrared Imaging Radiometer Suite
(VIIRS) aboard the Suomi-NPP (or Joint Polar Satellite System, JPSS; ~1:30 pm and
~1:30 am local time overpass; available since late 2015) satellite. Coastlines and place
labels can be overlaid on these base images. Click and drag to move around and zoom in/
out to focus on regions of interest.

b) For this example, we will use the 13 February 2014 explosive eruption of Kelut (Java,
Indonesia; lat: 7.93°S, lon: 112.308°E), although feel free to explore any other eruption of
interest (e.g., from the Smithsonian Institution Global Volcanism Program database or the
supplied MSVOLSO2L4 database). The Smithsonian GVP report of the February 2014
Kelut eruption, which started at ~2300 local time (~1600 UTC) on February 13, is here.
You can also download a GRL paper describing some analysis of satellite data for the
Kelut eruption.

The first step is to navigate to the relevant date in Worldview and find Java
(Indonesia) on the map. Note that, since the eruption started late on February 13 (after the
Terra/Aqua MODIS daytime overpasses), the eruption cloud does not appear on the
February 13 MODIS visible images. To visualize the eruption cloud in this case we can
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d)

use nighttime infrared (IR) Brightness Temperatures (also available from MODIS, VIIRS
and many other satellite instruments).

To add a new data layer in Worldview, click ‘+ Add Layers’ and a menu will appear
listing available layers by ‘Hazards and Disasters’ or ‘Science Discipline’. The ‘Ash
Plumes’ collection provides access to several datasets useful for visualizing volcanic
plumes, including sulfur dioxide (SO2) data, aerosol data (for volcanic ash) and thermal
anomalies (sensitive to active lava).

To add a Brightness Temperature layer, start typing ‘Brightness Temperature’ in
the search field and many options will appear. Check the ‘Brightness Temperature (Band
31-Night)’ layer from Aqua/MODIS to add it to the display. This layer should now appear
in the list of ‘Overlays’ in the top left of the window; these can be switched on or off
using the ‘eye’ icon, and the order of the layer ‘stack’ can also be changed by dragging
layers up or down (it is useful to have the coastlines and place labels at the top so they are
overlaid on all other layers). The thresholds and color palette for the layer can also be
changed.

With the Brightness Temperatures displayed (which are from Aqua/MODIS at
~1:30 am local time on February 14, ~2.5 hrs after the Kelut eruption), the volcanic
umbrella cloud should be visible as a large, dark (i.e., low temperature) feature over East
Java (other similar features in the region are probably thunderstorm clouds). The cold
temperatures are consistent with an opaque cloud at high altitudes. By moving the mouse
over the cloud you can view the actual temperatures recorded on the scale bar. One way
of estimating volcanic cloud altitude is to compare the IR brightness temperatures with
the closest (in time and location) radiosonde atmospheric temperature sounding (e.g.,
obtained from the University of Wyoming). Do you notice anything unusual about the
temperature distribution in the volcanic cloud (especially over the location of Kelut),
relative to other cold clouds in the region?

Other useful layers to add for this nighttime case are accessed under ‘Ash Plumes’ ->
‘Sulfur Dioxide’:

i.  Aqua/AIRS Sulfur Dioxide (Night, Prata Algorithm)

il.  Aura/MLS Sulfur Dioxide (147 hPa, Night)

The IR Atmospheric Infrared Sounder (AIRS on NASA’s Aqua satellite) and Microwave
Limb Sounder (MLS) instruments can detect volcanic SO> at night (unlike the UV
sensors, OMI and OMPS). Note the unusual ‘ring-like’ SO2 distribution in the AIRS SO,
data which is due to high opacity (probably due to ice/ash) preventing SO> retrieval in the
center of the volcanic cloud (cloud transparency is required for SO; retrieval). MLS
provides a coarse vertical profile of SO2 in the upper troposphere and stratosphere along
the Aura satellite track — the MLS data in Worldview are for just one layer (147 hPa
pressure; ~14 km altitude).
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You can also add orbit tracks from various satellites to the data stack. The Cloud-Aerosol
Lidar and Infrared Pathfinder Satellite Observation (CALIPSO) satellite (https:/www-
calipso.larc.nasa.gov/), which carries a space-borne Light Detection and Ranging
(LiDAR) instrument, can measure the altitude of volcanic clouds directly if the satellite
track intersects the plume. Although CALIPSO LiDAR data cannot be visualized in
Worldview, the CALIPSO satellite tracks can be viewed to check for plume intersection,
since the CALIPSO, Aqua, and Aura satellites orbit in NASA’s A-Train constellation and
have very similar overpass times (within ~10 minutes).

To add CALIPSO Orbital Tracks, click ‘+ Add Layers’ and search for
‘CALIPSO’, then check ‘CALIPSO Orbital Track & Overpass Time (Descending/Night)’
to display the nighttime CALIPSO track (roughly coincident with the Aqua MODIS and
AIRS data). Note that the CALIPSO track cuts directly through the young Kelut eruption
cloud, which is a rare occurrence!

If you want to then go and find the corresponding CALIPSO browse image
showing the LiDAR backscatter data, you need to note the CALIPSO overpass time from
Worldview (~18:15 UTC on Feb 13 in this case), go to the CALIPSO website (https://
www-calipso.larc.nasa.gov), and browse to Products -> LIDAR Browse Images ->
Version 4 (Go) -> Select date (Feb 13, 2014) -> Search for the image panel corresponding
to the ~18:15 UTC overpass (orbital track maps are available to aid navigation). See if
you can locate the Kelut volcanic cloud feature in the CALIPSO data and obtain an
approximate altitude.

Note that all layers added to the stack are preserved as you navigate forward or backward
in time in Worldview. To visualize the dispersion of the Kelut eruption cloud in
subsequent days, you need to add other data layers available in daytime under ‘Ash
Plumes’ including:

i.  Aura/OMI UV Aerosol Index (for volcanic ash)

il.  Aqua/AIRS Sulfur Dioxide (Day, Prata Algorithm)

iii. Aura/MLS Sulfur Dioxide (147 hPa, Day)

iv.  Aura/OMI Sulfur Dioxide (Upper Troposphere and Stratosphere)

Note that Aura/OMI, Aura/MLS and Aqua/AIRS (daytime) measurements are roughly
coincident in time. Comparing these datasets provides some insight into the different
sensitivity to volcanic SOz in the UV (OMI) and IR (AIRS).

Finally, many of the visualized satellite datasets can be downloaded for further offline
analysis using the ‘Data’ tab at the top left of the screen. Satellite datasets are typically
packaged as entire satellite orbits (~14-15 orbits per day for a typical polar-orbiting asset)
or as ‘granules’ covering smaller geographic regions.

Satellite data visualization/extraction with NASA Panoply
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This exercise uses NASA’s free Panoply Data Viewer to visualize data. Panoply is less user-
friendly than Worldview, but provides more control over plotting parameters and access to the
full range of variables provided in satellite data files (HDF or netCDF). As with Worldview,
minimal quantitative analysis is possible with Panoply (its main function is to produce images)
but data can be extracted for further analysis if needed.

Panoply is a Java application that enables the user to plot raster images of geo-gridded (geo-
referenced) data from datasets in netCDF or HDF format. Depending on the type of data
available, Panoply can be used to create displays in a variety of ways:

* Plot longitude-latitude data as global maps or zonal averages, using any of over 40 global map
projections

* Overlay continent outlines or masks on longitude-latitude plots, or just plot a particular region
* Display specific latitude-longitude or latitude-vertical arrays from larger multidimensional
variables as slices

Panoply also functions as a tool for graphical data analysis and reporting of results by allowing
the user to:

» Combine two arrays in one plot by differencing, summing or averaging
* Use any of the 30 scale colorbars provided, or add a custom colorbar
» Save plots to disk as PNG or GIF images

For this example, we will use the 26-27 July 2018 eruption of Ambae (or Aoba, Vanuatu; lat:
15.389°S, lon: 167.835°E), which produced significant SO, emissions. This exercise uses two
current satellite SO, datasets, from the ESA/Sentinel-5P TROPOMI instrument and the NASA
Suomi-NPP OMPS instrument. These are both UV instruments, but TROPOMI has higher spatial
resolution and hence greater sensitivity to volcanic SOz. As before, feel free to explore any other
eruption of interest (e.g., from the Smithsonian Institution Global Volcanism Program database
or the supplied MSVOLSO2L4 database).

To locate the relevant TROPOMI orbit covering the Ambae volcanic cloud and load it into
Panoply:

a) Go to the Sentinel-5P Hub: https://sSphub.copernicus.eu/dhus/#/home
b) Drag the map to the area of interest (Vanuatu) and draw a box over and to the east of
Vanuatu (to do this you need to activate ‘area mode’ using the box icon at top right of the
window).
c) Click the bars on the left of the Search window (top left) to bring up Advanced Search
options, and enter the following:
a. Sensing period: start: 2018/07/27; stop: 2018/07/27
b. Product Type: L2 SO2
c. Timeliness: Reprocessing
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d)

Then click the magnifying glass icon to search. You will be prompted to login using the
username/password: sSpguest/sSpguest, then you may need to hit search again.

The results should list 1or 2 TROPOMI orbits that intersect your search box. ‘Mousing
over’ the results will illuminate the corresponding orbit on the map. The results also show
a Download URL for each orbit — rather than downloading the files (which are quite
large), you can copy this URL and paste it in the ‘Enter the URL of a remote dataset to
open:’ window in Panoply. You will be prompted to login to Sentinel Hub again
(s5pguest/sSpguest) and then the remote dataset should load (may take some time
depending on connection speed).

In case of problems, here’s the direct link to TROPOMI orbit for Ambae on July 27, 2018
(Sentinel Hub): https://sSphub.copernicus.cu/dhus/odata/v1/Products('64balebd-
cb68-416¢e-a45d-8ca7e4dd059a')/$value

Once loaded into Panoply, the structure of the TROPOMI data files (HDF version 5) can be
explored in the ‘Datasets’ tab. There are many parameters stored in the files, but to plot a map of
SOz select:

$value -> PRODUCT -> SUPPORT DATA -> DETAILED RESULTS ->
sulfurdioxide total vertical column_ 15km

Then click ‘Create Plot’ or right-click on the variable to create a plot. Select the option ‘Create a
georeferenced Longitude-Latitude plot’, then ‘Create’. Plotting may take some time as the data
are being read remotely. A window should open with a plot of the TROPOMI orbit on a global
map. To zoom in to the area of interest (Vanuatu) you need to hold ‘Command’ (on a Mac) and
draw a new box; zoom out using ‘Option-Command’ (or use the Plot menu).

Tabs at the bottom of the plot window allow you to change various plotting parameters:

Array(s) — checking the ‘Interpolate’ box produces a smoothed map; unchecking the box
displays the actual sensor ground-pixels.

Scale — change the range of the plotted data (e.g., remove negative values by setting Min
to zero); change the color table and caption. Nofe: the units of TROPOMI SO: columns
are moles m2; to convert these to the more commonly used Dobson Units (DU; 1 DU =
2.69x10 molecules cm2 = 0.0285 g m2 SO2) you would need to multiply by a scaling
factor of 2241.15, but unfortunately it is not easy to do this in Panoply.

Map — change map projection; re-center the map (note that the July 27, 2018 eruption
cloud from Ambae straddles the International Date Line, so try centering on 180°E); add a
graticule and labels.

Overlays — add coastlines and country borders (MWDB_ Coasts Countries 1.cnob is
high-resolution data, useful for small regions).

Contours — add contours to the data plot.

Labels — Add/change plot title, footnotes etc.
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When you are happy with the plot you can save it using File -> Save Image As.. (default
format is PNG). You can also export the maps as KMZ files (e.g., for display in Google Earth
or GIS software). To export the actual data (e.g., for use in a spreadsheet or other data
analysis tool), highlight the variable of choice in the ‘Datasets’ tab (Panoply — Sources
window) and use File -> Export Data.

You can now repeat this procedure to locate and load OMPS SO> data for the same Ambae
eruption (hard copies of data files will also be provided):

f) To search for the OMPS data yourself, you can use the NASA Earthdata portal (https://
search.earthdata.nasa.gov/search?q=OMPS_NPP_NMSO2 PCA_L2), which requires
you to register for a free account to download data. Then choose a region and date of
interest, search for corresponding data granules (OMPS-NPP_NMSO2*.hS5 files) and
either download the data files or copy the access URLs from the ‘Information’ tab for
each granule for use in Panoply. Detailed instructions are not provided here but it is fairly
intuitive.

g) Alternatively, here is the direct link to an OMPS SO: data file for the Ambae eruption
that you can use in Panoply (this also requires an Earthdata account for download,
however: https://measures.gesdisc.eosdis.nasa.gov/data/SO2/
OMPS_NPP_NMSO2 PCA L12.1/2018/208/OMPS-NPP_NMSO2-PCA-

L2 vl.1 2018m0727t013256 034954 2018m0727t060604.h5

h) Once you have the data file URL, you can paste it in the ‘Enter the URL of a remote
dataset to open:” window in Panoply as before. It will then appear in the ‘Datasets’
window under the TROPOMI data file. Alternatively, you can load a local data file from
your hard disk using File -> Open...

1) To locate the SO2 variable, select OMPS-NPP_NMSO?2... -> SCIENCE_DATA ->
ColumnAmountSO2_STL (stratospheric SOz column amount). Now you have two
options: make a new plot window (-> Create Plot) or combine the OMPS SO> data with
the previously plotted TROPOMI data (-~ Combine Plot). In the latter case, you will be
asked in which existing plot you should combine the variable. Then in the combined plot
window, you can toggle between the TROPOMI and OMPS SO: data using the Array(s)
tab:

a. Plot Map of Array 1 Only — TROPOMI
b. Plot Map of Array 2 Only — OMPS

Again, unchecking ‘Interpolate’ shows the native satellite spatial resolution. This is useful
for comparing the high resolution TROPOMI observations (3.5x7 km) with the lower
resolution OMPS (50x50 km). However, due to the different units used in the TROPOMI
(mol m-2) and OMPS (DU) files, you need to change the scaling on the ‘Scale’ tab using
‘Fit to Data’

j)  You may find it easier to open the OMPS SO data in a new plot window (-> Create Plot)
for a side-by-side comparison. Compare the sensitivity and extent of the Ambae SO: cloud
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as observed by TROPOMI and OMPS (which have similar overpass times at ~1:30 pm
local time).

Additional activities: try searching for and loading adjacent TROPOMI and/or OMPS orbits
from the same day or subsequent days to increase spatial coverage (the Ambae SO> cloud spread
over the southern Pacific Ocean in the 1-2 weeks after the eruption). You can also try visualizing
the OMPS UV Aerosol Index data (sensitive to volcanic ash) in Panoply, or visualizing the
OMPS data (and other datasets) for the Ambae eruption in NASA Worldview as described in (1)
above. TROPOMI data are not currently available in Worldview but can be visualized (along
with many other ESA Sentinel datasets) in the similar Sentinel EO Browser (https://
apps.sentinel-hub.com/eo-browser).

More information on Panoply is available in these manuals:

https://earth.usc.edu/files/ge-labs/EdGCM/Documentation/Panoply Manual.pdf
https://www.geo.uni-bremen.de/Interdynamik/images/stories/pdf/visualizing_netcdf panoply.pdf
https://disc.gsfc.nasa.gov/information/howto?
title=Quick%20View%20Data%20with%20Panoply

3. Online satellite data analysis using NASA Giovanni

In this final visualization exercise, we will explore the use of NASA’s Giovanni application
(https://giovanni.gsfc.nasa.gov/giovanni) for online satellite data analysis. In contrast to
Worldview and Panoply, which are primarily data visualization tools, Giovanni can be used to
analyze large amounts of satellite data online without downloading the files. Satellite data
animations can also be generated. Here, we will use Giovanni to create a time-averaged map of
satellite SO» data to detect and visualize passive volcanic degassing. The only relevant satellite
SO: dataset currently available in Giovanni is from the NASA Ozone Monitoring Instrument
(OMI). Some generic instructions are provided below, but you are encouraged to explore
different volcanic regions and time periods to visualize the variability in volcanic degassing.

Note: although limited functionality in Giovanni is available as a ‘guest user’, a free NASA
Earthdata account provides full access.

(a) From the Giovanni home page, various plot types are available under ‘Select Plot’ (e.g.,
time-averages, cumulative plots, comparisons, vertical profiles, etc). Select the first
option: ‘Maps: Time Averaged Map’.

(b) Next, Select Date Range (UTC) for the time-averaging. This is your choice, but you may
want to experiment with annual, seasonal or monthly averages. Note that the OMI SO-
dataset used for analysis is available from October 2004 to present. The stronger the
volcanic SO2 source, the less data averaging is required to ‘detect’ the source in satellite
data, and vice versa.
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(c) Next, Select Region (Bounding Box or Shape) for analysis, using the ‘Draw bounding
box on map’ tool. Use the ‘hand’ to roam around the map, then zoom in to your region of
interest and draw a box. The smaller the box, the faster the analysis will run. The choice
of region is up to you, but some global volcanic SOz emission ‘hotspots’ include Vanuatu,
Papua New Guinea, Hawaii (Kilauea), Mexico, Colombia/Ecuador, southern Peru, and
Sicily (Etna). More details on volcanic SO> sources are here.

(d) Now, Select Variables. Under ‘Measurements’, check the SO> box. Four available
datasets should appear in a Table. Select ‘SO2 Column Amount (Planetary Boundary
Layer) OMSO2e v003’, which is the OMI SO> dataset. The other SO> datasets listed are
model output from the MERRA-2 Model (not actual observations), but you could also try
plotting these for comparison with the OMI SO; data. In the model data, SO> emissions
are simulated using emissions inventories.

(e) Now hit ‘Plot Data’ in the bottom right of the window, and the data analysis will be
launched. This may take some time, depending on the selected time-period and size of
region.

(f) Once complete, a map of time-averaged OMI SO: columns will appear. Various aspects
of the map can be changed using the ‘Options’ menu; e.g., change the scale, color palette,
caption, title etc. Maps can also be downloaded as GeoTIFF, KMZ or PNG files.
Unfortunately, volcano locations cannot be plotted — see which volcanoes you can
identify based on their SO2 emissions.

(g) Further analysis using Giovanni could include comparison of annual or monthly mean
SOz maps for a particular volcano; e.g., Kilauea’s SOz emissions increased significantly
after the summit eruption in March 2008. You could also experiment with some other
tools available in Giovanni (e.g., data animation).
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Other exercises
Calculation of the sulfur budget for the 2011 Grimsvotn (Iceland) eruption

This exercise is an example of a common problem in volcanic emission studies: inferring the
total volcanic sulfur budget based on measured emissions of only 1 or 2 sulfur species.

Goal: calculate the sulfur (S) budget of the May 2011 explosive eruption of Grimsvétn (Iceland)
based on satellite remote sensing measurements of degassing and petrological data (S

concentrations in the melt), and estimates of other sulfur sinks in the volcanic system.

Satellite remote sensing data and derived estimate of other sulfur species

The following sulfur gas species were measured or estimated in the Grimsvétn eruption cloud
[Sigmarsson et al., 2013]:

0.3 Tg SOz (OMI measurements)
29 Gg Ha2S (IASI measurements)
15 Gg S> (estimated based on assumed gas ratios)

1 Tg=1012¢g
1Gg=100¢g

Ash leachate data

An estimated 118 Gg S was sequestered on volcanic ash in the eruption column [Olsson et al.,
2013]

Petrological estimate of Grimsvétn SO, emissions

64
Degassed SOz mass = EPVDRE(Si - Sg)

Si=0.1750 wt%
Sg = 0.0687 wt%
Vpre = 0.25 km3

Where 64/32 = ratio of molecular weights of SO> and S; p = 2750 kg m-3 (melt density); Vpre =
0.25 km3 (eruption volume, Dense Rock Equivalent); S; = initial S concentration (from melt
inclusions); Sg = residual S concentration after degassing (from groundmass).

Other sulfur sinks
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Other potential sinks for S in the Grimsvétn system are:
S lost to hydrothermal system and caldera lake (Siake) =37 Gg S
S conserved in the magma as sulfide globules (Ssuifide globutes). Sulfide globules were observed in

the erupted products.

Total S mass balance for 2011 Grimsvitn eruption

Si— (Sg + Ssatellite T Steachate + Siake + Ssulfide globules) =0

Step 1: calculate the total eruptive S emission (as SO2, H2S and S») based on satellite
measurements.

Step 2: estimate the total S emission, accounting for the S scavenged in the eruption column.
What proportion of the emitted S was scavenged and returned to the ground in ashfall?

Step 3: calculate the petrological estimate of SO emissions, and compare this with the satellite
observations.

Step 4: estimate the amount and proportion of the total S budget conserved in the magma as
sulfide globules, according to the mass balance equation provided.
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